Security Update Notification

This is a notification of security updates for your website and/or online forms.

No action is required on your part.

Transport Layer Security (TLS) is the encryption technology used to protect communications to and from your website and/or online forms. As vulnerabilities are found in older versions of the technology it becomes necessary to discontinue use of those versions.

To be compliant, Practis will be removing TLS 1.0 and TLS 1.1 from its servers over the next few weeks. After the removal all connections to Practis Forms will need to use TLS 1.2.

Compatibility will be dependent on the customer's web browser supporting TLS 1.2. A list of compatible web browsers is below.

Web Browser TLS 1.2 Compatibility

  • Microsoft Internet Explorer (IE) 11 or above
  • Microsoft Edge all versions
  • Google Chrome 38 or above
  • Mozilla Firefox 27 or above
  • Apple Safari 7 or above

Operating System TLS 1.2 Compatibility

  • Microsoft Windows 7 or above
  • Microsoft Windows Server 2008 R2 SP1 or above
  • Apple OS X 10.9 or above
  • Apple iOS 5 or above
  • Android 4.4 or above

Have more questions? Submit a request